(編集中)

環境

OS:mac osx 10.10.4 (yosemite)
python:3.5.2

IDLEを起動したらWARNINGでた

これ↓

WARNING: Running IDLE without a Subprocess is deprecated
and will be removed in a later version. See Help/IDLE Help
for details.

>>> WARNING: The version of Tcl/Tk (8.5.9) in use may be unstable.
Visit http://www.python.org/download/mac/tcltk/ for current information.

サブプロセスなしでIDLEを起動しちゃだめだよ
Tcl/Tkのバージョン8.5.9は不安定だよ。今の情報を調べて最新版をいれな
の二つ

Tcl/Tkってなんだ

wikiより
てぃくるてぃーけーね

Tcl/Tk(ティクル・ティーケー)は、スクリプト言語 Tcl と、その GUIツールキット Tk を指す。非常に強力な GUI ツールキットと、シンプルな文法をもつ言語により、GUI ツールを素早く作り上げるのに適した強力なスクリプティング環境である。

macOSでIDLEとtkinaterを使う際の注意事項

pythonページに本件についての情報あり

  • mac os x 10.6以上で64/32bitのpythonを使うなら、ActiveTcl8.5のようなサードパーティー製のアップデート版Tcl/Tk8.5をつかえ